Shopping List has gone wonky

Found a problem? Post details on BeerTools Pro errors and how they are caused.
Post Reply
beerphoto
Light Lager
Light Lager
Posts: 25
Joined: Tue Apr 11, 2006 9:02 pm
Location: Northern Michigan

Shopping List has gone wonky

Post by beerphoto » Mon Feb 21, 2011 12:10 pm

Hey guys,

First off, I love your program, have been with it from the beginning and haven't had any problems with how I use it.

One of my favorite features is the shopping list but mine has suddenly gone wonky on me.

I've got three recipes dragged into "Planned Recipes" and when I open my shopping list, it's only picking up some of the ingredients. Many are missing.

And here's the other odd thing -- one of the ingredients shows up on the list - but has no totals - no numbers at all in any of the columns.

Would be happy to take a screen shot and send it along.

beerphoto
Light Lager
Light Lager
Posts: 25
Joined: Tue Apr 11, 2006 9:02 pm
Location: Northern Michigan

Post by beerphoto » Mon Feb 21, 2011 12:12 pm

I should've added I'm on 10.6.6 OS. I recently upgraded to Snow Leopard but I'm fairly certain my Shopping List has functioned properly since then.

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1507
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Shopping List has gone wonky

Post by jeff » Mon Feb 21, 2011 3:12 pm

beerphoto wrote:Hey guys,

First off, I love your program, have been with it from the beginning and haven't had any problems with how I use it.

One of my favorite features is the shopping list but mine has suddenly gone wonky on me.

I've got three recipes dragged into "Planned Recipes" and when I open my shopping list, it's only picking up some of the ingredients. Many are missing.

And here's the other odd thing -- one of the ingredients shows up on the list - but has no totals - no numbers at all in any of the columns.

Would be happy to take a screen shot and send it along.
Hard to figure out without seeing it myself. You can zip your entire library folder and send it if you want me to look at it.

Thanks
Jeff
BeerTools.com Staff

discooby
Posts: 4
Joined: Sun Aug 07, 2011 4:18 am

Post by discooby » Tue Oct 11, 2011 11:47 am

I'm having (had) this problem since 1.5.17 and now 1.5.18. Shopping list does not pick up ingredients for planned recipes and acts funny (sometimes will only show one ingredient). If I have two recipes in the planned folder but only want to assemble 1, nothing shows. But if I assemble both the recipes it shows for the 2nd, not the first (i.e., I want to figure how much to order for a dunkle (purchase vs in stock) and also have a choc stout for later down the road, I have to add the choc stout to see the dunkel)... it then still doesn't show how much I need to purchase (in stock - assemble = remaining/purchase). I'm on a win 7 pro 64 bit. This sucks! I guess I need to check the old fashion way and look at my 1st grade math books for a refresher... :shock:

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1507
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Post by jeff » Wed Oct 12, 2011 9:30 am

discooby wrote:I'm having (had) this problem since 1.5.17 and now 1.5.18. Shopping list does not pick up ingredients for planned recipes and acts funny (sometimes will only show one ingredient). If I have two recipes in the planned folder but only want to assemble 1, nothing shows. But if I assemble both the recipes it shows for the 2nd, not the first (i.e., I want to figure how much to order for a dunkle (purchase vs in stock) and also have a choc stout for later down the road, I have to add the choc stout to see the dunkel)... it then still doesn't show how much I need to purchase (in stock - assemble = remaining/purchase). I'm on a win 7 pro 64 bit. This sucks! I guess I need to check the old fashion way and look at my 1st grade math books for a refresher... :shock:
As mentioned previously, I'm driving blind unless I plug your DB into my installation. You can zip your entire library folder and send it if you want me to look at it.

Thanks
Jeff
BeerTools.com Staff

User avatar
ColoradoBrewer
Strong Ale
Strong Ale
Posts: 282
Joined: Tue Oct 24, 2006 11:32 am
Location: Fremont County, CO

Post by ColoradoBrewer » Sun Oct 16, 2011 9:37 am

Jeff, I think I'm having this problem as well. I have a zipped copy of my database and will send it shortly.
BTP 2.0.22 (Linux (.deb) 64 bit)
BTP 2.0.24 (Windows 10 64 bit)

User avatar
ColoradoBrewer
Strong Ale
Strong Ale
Posts: 282
Joined: Tue Oct 24, 2006 11:32 am
Location: Fremont County, CO

Post by ColoradoBrewer » Sun Oct 16, 2011 10:11 am

Email sent.
BTP 2.0.22 (Linux (.deb) 64 bit)
BTP 2.0.24 (Windows 10 64 bit)

discooby
Posts: 4
Joined: Sun Aug 07, 2011 4:18 am

Post by discooby » Tue Oct 18, 2011 5:47 pm

I submitted a trouble ticket (and attached the Recipes folder zipped) as I do not have an email client installed on my computer (unless there is another way to send you an email?). Also, as I am still new to beertoolspro, when you say library I assume you are refering to the recipes folder? Thanks for your help,
Regards,

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1507
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Library folder

Post by jeff » Wed Oct 19, 2011 7:52 am

discooby wrote:I submitted a trouble ticket (and attached the Recipes folder zipped) as I do not have an email client installed on my computer (unless there is another way to send you an email?). Also, as I am still new to beertoolspro, when you say library I assume you are refering to the recipes folder? Thanks for your help,
Regards,
I viewed your support ticket. The "library" folder - probably named "BeerTools Pro" - contains the "Recipes" folder and the "Beertools Pro Library.rsd" file. I need the entire folder containing both items since they are interdependent.

I've received files from several of you and it may take some time to identify the problem. Thanks for your patience.
Jeff
BeerTools.com Staff

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1507
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Shopping List has gone wonky

Post by jeff » Fri Oct 28, 2011 12:48 pm

I fixed some issues I found in the shopping list window which will likely solve many of the behaviors you have observed. However, there is one problem that is only resolved by verifying that ingredients in the recipe are still related to ingredients in the my ingredients folder.

Version 1.5.19 adds the ingredient ID to the bottom of the info window when showing information for each ingredient. Any ID greater than 65535 references an inventory ingredient. IDs up to 65535 are found in the permanent ingredient DB. If the ID is missing it means that the ingredient is not found in the database at all. The "replace in recipe" feature can be used to re-associate ingredients with their source records in the DB.

This version also adds the "in stock" quantity to the info window which makes knowing inventory amounts easier. Clicking on ingredients in the recipe while the info window is visible reveals how much of the ingredient is in inventory.

Hopefully these changes eliminate most, if not all, wonkiness from the shopping list, and make resolving inconsistencies quick and easy.
Jeff
BeerTools.com Staff

User avatar
ColoradoBrewer
Strong Ale
Strong Ale
Posts: 282
Joined: Tue Oct 24, 2006 11:32 am
Location: Fremont County, CO

Thanks!

Post by ColoradoBrewer » Sat Oct 29, 2011 9:58 am

I've played around with new version a little and the problem appears to be fixed.
BTP 2.0.22 (Linux (.deb) 64 bit)
BTP 2.0.24 (Windows 10 64 bit)

discooby
Posts: 4
Joined: Sun Aug 07, 2011 4:18 am

Post by discooby » Fri Nov 04, 2011 1:48 am

Thanks jeff,

The shopping list is now working right for me. Also, I didn’t need to re-associate ingredients (after checking ID’s), ingredients in recipes are from my ingredients folder (inventory)… not sure if that helps any. Thanks again,
:D

beerphoto
Light Lager
Light Lager
Posts: 25
Joined: Tue Apr 11, 2006 9:02 pm
Location: Northern Michigan

Post by beerphoto » Mon Nov 14, 2011 10:43 am

So far so good. Mine's working properly as well. Thanks, Jeff!

Post Reply