Strange error on startup

General discussion on BeerTools Pro Software.
Post Reply
Circle7
Light Lager
Light Lager
Posts: 10
Joined: Wed Aug 26, 2015 2:10 pm

Strange error on startup

Post by Circle7 » Wed Feb 01, 2017 6:20 pm

Hi Folks,

Long time BTPro user and have been on 2.0 for quite a while. Recently, when starting up, I get the error in the attached picture. This shows up when starting the software either from double clicking a recipe for the root .exe.

I tried uninstalling the software and reinstalling with the latest available from the website, but the error remains.

The strange thing is that if you click either cancel, try again or continue 3 times, the software will start up and run semi-normally. There are strange font issues....things just don't quite "look" right, but it runs.

Any thoughts?

Thanks!
Attachments
BTPro Error.png
BTPro Error.png (25.29 KiB) Viewed 5935 times

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1510
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Strange error on startup

Post by jeff » Thu Feb 02, 2017 9:10 am

Strange indeed!

That looks like a Windows error message. There may be some issues with your operating system.

If you are able to get the program to run you can check the location of the library folder in preferences. It may be looking for the library folder on the missing device.
Jeff
BeerTools.com Staff

Circle7
Light Lager
Light Lager
Posts: 10
Joined: Wed Aug 26, 2015 2:10 pm

Re: Strange error on startup

Post by Circle7 » Thu Feb 02, 2017 10:06 am

The add/remove programs is not removing all of the components. It is leaving this brokenness behind. Can you please tell me all the locations that this software places files so I can manually strip them and try a fresh install?

Windows is operating ok.

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1510
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Strange error on startup

Post by jeff » Thu Feb 02, 2017 10:16 am

Typical locations:
C:\Users\<username>\AppData\Roaming\BeerTools Pro
C:\Users\<username>\Documents\BeerTools Pro
Jeff
BeerTools.com Staff

Circle7
Light Lager
Light Lager
Posts: 10
Joined: Wed Aug 26, 2015 2:10 pm

Re: Strange error on startup

Post by Circle7 » Thu Feb 02, 2017 10:49 am

It was the roaming data folder. That isn't removed by add/remove. Once manually removed, program reinstalled, all is working normally again.

Thanks!

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1510
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Strange error on startup

Post by jeff » Thu Feb 02, 2017 11:31 am

That folder contains the preferences file. It must have been corrupted. Glad everything is working now.
Jeff
BeerTools.com Staff

Post Reply