Template Woes...

General discussion on BeerTools Pro Software.
Post Reply
User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

Template Woes...

Post by wottaguy » Sat Nov 25, 2006 1:57 pm

Hi Guys!
I have taken the time to create a very accurate template and have made it be the Default Template. When I launch BtPro it loads with all my preset settings correctly. When I load a downloaded and saved recipe, The template is not applied. Is there a way to apply my default template to any recipes and retain my system settings to any and all downloaded recipes without me having to manually go in and change the settings myself? I thought a Default Template would carry over your settings to any recipe opened by the application? Maybe i'm doing something wrong??
Thanks for any help you can offer!
Ron

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1515
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Template Woes...

Post by jeff » Sat Nov 25, 2006 2:15 pm

wottaguy wrote:Hi Guys!
I have taken the time to create a very accurate template and have made it be the Default Template. When I launch BtPro it loads with all my preset settings correctly. When I load a downloaded and saved recipe, The template is not applied. Is there a way to apply my default template to any recipes and retain my system settings to any and all downloaded recipes without me having to manually go in and change the settings myself? I thought a Default Template would carry over your settings to any recipe opened by the application? Maybe i'm doing something wrong??
Thanks for any help you can offer!
Ron
The default template is applied when creating a new session. You can also load a template into an existing session by selecting File->Load Template. If you don't have a copy of your default template saved somewhere you have two options.

First, you can choose File->Load Template and find the file location of the default template on your drive. If you are using Windows this may be difficult since so many files are hidden.

Second, you can create a new session and before doing anything, save the session as a template somewhere accessible. You can save a template with File->Save As Template.

When saving the template, only check the items that you don't mind getting overwritten when applying the template to sessions opened in BTP.

Once you have your template somewhere where you can locate it, you can load it into any session that you have open in BeerTools Pro.
Jeff
BeerTools.com Staff

User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

Post by wottaguy » Sat Nov 25, 2006 2:35 pm

Jeff...
I have saved my template and designated it to be the default template for any new recipe to be created. My question is How do I get bTpro to always use my default template whenever I open a saved, downloaded recipe..I have tried to apply my template to the recipe in question but when I do that I get an empty window with only the template settings. So as it is now, the default template cannot be used or applied to any existing recipes created by others and it is only used for creating new recipes? I would think that a "Default Template" would be a global application setting.. once it is designated as being the default template, it should carry over to any recipe opened within the app. If I can only use my Default Template to create NEW recipes only...then I feel that I am getting 50% functionality from the software? How about asking the user whether he wants to apply a template to any recipe that is about to be opened in the app? Or even a pair of buttons that give the user the option to apply a template OR to view the original recipe settings? I don't have the time to input all my brew system settings for every downloaded recipe that I have....i'd rather be brewing than fooling around with software settings and such.
Also...would it be possible to have some kind of indicator of what template is currently loaded and is being used? I have 2 very different brew systems and would like a quick way to determine which Template is currently being used.

Thanks again!
Ron

steinbierz
Light Lager
Light Lager
Posts: 15
Joined: Tue Oct 24, 2006 9:34 am
Location: Springfield, VA (D.C. Metro Area)

Post by steinbierz » Sun Nov 26, 2006 10:09 am

I am having the same problem as wottaguy. I followed the directions i.e. loaded an existing program and then tried to load the template over it. The template information appears as well as the category and subcategory of the recipe I had loaded. However, no ingredients.

As a former (and still I guess until I get BTP figured out) ProMash user, I like being able to set defaults separate from my recipes and knowing that they will apply these defaults to any new recipe or session I open up. Of course, the ability to go in and change things that differ from your system settings is available in ProMash as well.

BTW, I am using the Mac software.

Thanks.

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1515
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Template config

Post by jeff » Sun Nov 26, 2006 11:32 am

steinbierz wrote:I am having the same problem as wottaguy. I followed the directions i.e. loaded an existing program and then tried to load the template over it. The template information appears as well as the category and subcategory of the recipe I had loaded. However, no ingredients.
Was the ingredients checkbox unchecked in the template configuration pane when the template was saved?
Jeff
BeerTools.com Staff

User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

Post by wottaguy » Sun Nov 26, 2006 11:39 am

I had the ingred box checked...the only boxes i had un checked were Mash Schedule,Notes and Water Profile..all others are checked. Running Win XP here all updated IE 6 tho..

User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

Same Results With ver 1.0.11

Post by wottaguy » Sun Nov 26, 2006 11:53 am

Jeff...
I get the same results as above with ver 1.0.11..i'll open a recipe that I have saved to my disk..when open it displays the original settings as the owner of file..when I go to apply the template i get a blank window with just the template settings...when i try to reopen the same recipe, i get no response from the app..
The template was saved with all checked execpt for what i had from previous post..and also declared as the Def Template.

hope this helps!

steinbierz
Light Lager
Light Lager
Posts: 15
Joined: Tue Oct 24, 2006 9:34 am
Location: Springfield, VA (D.C. Metro Area)

Re: Template config

Post by steinbierz » Sun Nov 26, 2006 2:48 pm

jeff wrote:
steinbierz wrote:I am having the same problem as wottaguy. I followed the directions i.e. loaded an existing program and then tried to load the template over it. The template information appears as well as the category and subcategory of the recipe I had loaded. However, no ingredients.
Was the ingredients checkbox unchecked in the template configuration pane when the template was saved?
Yes it was unchecked. I assumed, maybe incorrectly, that if you hadn't saved ingredients in a template that there would be no reason to check the ingredients box. Is this incorrect? Thanks.

BTW, I think you figured out what I was saying in my question. I meant "loaded an exisitng recipe" NOT program.

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1515
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

thanks for the details..

Post by jeff » Sun Nov 26, 2006 5:40 pm

Ok, I will take a look at the template loading routine and see if there is something in there that would cause it to dump the ingredients in the existing recipe.
Jeff
BeerTools.com Staff

User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

Any Progress??

Post by wottaguy » Wed Nov 29, 2006 11:14 am

Hi Jeff....

Has there been any findings and or progress concerning my template questions and problem? Just wondering!

Thanks..

Ron
Visit my blog @ http://www.wottashomebrewblog.blogspot.com

On Tap:
HL Pale Ale
HL Lite Lager
Bottled:
HL Simcoe Pale Ale
HL Wizeguy Weizenbock
HL Reveur Saison
HL Dry Stout
HL Kentucky Common

User avatar
jeff
Imperial Stout
Imperial Stout
Posts: 1515
Joined: Sun Jan 09, 2000 8:16 pm
Location: Hollywood, SC
Contact:

Re: Any Progress??

Post by jeff » Wed Nov 29, 2006 11:04 pm

wottaguy wrote:Hi Jeff....

Has there been any findings and or progress concerning my template questions and problem? Just wondering!

Thanks..

Ron
I did some tests on templates and I couldn't find anything wrong with the function of loading templates. I saved a template with the ingredients checkbox unchecked, and when I loaded it into another recipe, my ingredients in that recipe were preserved. Don't forget that if you save a recipe without ingredients as a template, failure to uncheck the ingredients box will cause the ingredients of a recipe the template is loaded into to be deleted.

I am still looking into possibilities for implementing a system for applying default templates to loaded recipes.
Jeff
BeerTools.com Staff

User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

i'll give it a try

Post by wottaguy » Thu Nov 30, 2006 5:44 am

ok..thanks Jeff..i'll give it a try!
Visit my blog @ http://www.wottashomebrewblog.blogspot.com

On Tap:
HL Pale Ale
HL Lite Lager
Bottled:
HL Simcoe Pale Ale
HL Wizeguy Weizenbock
HL Reveur Saison
HL Dry Stout
HL Kentucky Common

User avatar
wottaguy
Strong Ale
Strong Ale
Posts: 361
Joined: Thu Aug 11, 2005 10:00 am
Location: Florida
Contact:

Works!

Post by wottaguy » Thu Nov 30, 2006 5:48 am

Thanks Jeff..worked ok that time! I'll have to get used to the way it works i guess!
Visit my blog @ http://www.wottashomebrewblog.blogspot.com

On Tap:
HL Pale Ale
HL Lite Lager
Bottled:
HL Simcoe Pale Ale
HL Wizeguy Weizenbock
HL Reveur Saison
HL Dry Stout
HL Kentucky Common

Post Reply