BeerBot forgetting registration information

Have a question about BeerBot? Ask BeerBot users a question before you upgrade to the full version.

Moderator: lathe

BeerBot forgetting registration information

Postby goodbyesoberday » Thu Jun 02, 2005 9:03 am

I've noticed that frequently BeerBot will forget I have registered it, and revert to unlicensed mode. This is frustrating but not crippling as I can just reenter my registration details.

Any ideas as to the problem?

Running 10.3.9
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

how often?

Postby jeff » Thu Jun 02, 2005 11:37 pm

Does it forget every time you open it? We have to work to figure out what is happening on your machine because your registration code expires after 30 days. We will have to issue you a new one in that case.
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1401
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

Postby goodbyesoberday » Sat Jun 04, 2005 7:14 am

It does not do it every time, and when it does all my other preferences (eg last entered values in each category) do remain.

The last time it happened to me, it occurred while I was in the middle of using the program. I was calculating some hop utilisation values, and the next thing I knew the %Util tab had greyed out as had all other features not available in unregistered mode.

I just quit and relaunched the app ten times without drama.

I'm about to repair permissions to see if that helps, will try to use the app heavily in the next few days to see if the problem pops up again.
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

Relaunching the app..

Postby jeff » Sat Jun 04, 2005 12:55 pm

goodbyesoberday wrote:I just quit and relaunched the app ten times without drama.


When you quit and relaunched, did the problem resolve without re-entering the license key?
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1401
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

Having the same problem, but worse

Postby rexpolarhunt » Sat Jun 04, 2005 5:31 pm

I fired up BeerBot for the first time in a few weeks, and it says "Sorry, this license key has expired."

I tried again - no luck. I reinstalled BeerBot, still the same message.

I was planning on brewing tomorrow with BeerBot! Help!
rexpolarhunt
 
Posts: 3
Joined: Sun Feb 13, 2005 12:35 pm
Location: Northern Virginia

Re: Relaunching the app..

Postby goodbyesoberday » Sun Jun 05, 2005 4:03 am

jeff wrote:
goodbyesoberday wrote:I just quit and relaunched the app ten times without drama.


When you quit and relaunched, did the problem resolve without re-entering the license key?


Sorry, no, that was after re-entering the key. Once it thinks it's unregistered the key has to be re-entered.
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

It's done it again

Postby goodbyesoberday » Mon Jun 06, 2005 8:47 pm

Most notable thing I've done in the duration is installed new software through SWupdate and restarted, but I know it happens without a restart.
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

Have you used the terminal window before?

Postby jeff » Tue Jun 07, 2005 8:35 am

Couple things you might try while we work on figuring out the issue. Keep BeerBot in your home directory Applications folder (not the root level Applications folder). BeerBot stores the license information in a file inside the BeerBot folder and you can see if it exists by using the Terminal (found in /Applications/Utilities). If you start up the terminal, type this command after moving the BeerBot folder to your home Applications folder:
Code: Select all
cd Applications/BeerBot1.0

Then list the directory:
Code: Select all
ls -la

In the listing you should see a file called .license. If the problem happens, it would be helpful if you tell me if that file is there, and who the owner and group for the file is. The terminal listing will also tell you what permissions are set on the file which will help also.
Once we get an idea of what is happening, we will compile a new download. Thanks for your patience!
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1401
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

Postby goodbyesoberday » Wed Jun 08, 2005 3:51 am

Why should it be in the home directory? I prefer to keep my apps in the root level apps folder, not that it's really a huge issue. Though I did notice I hadn't even bothered moving the beerbot folder off the desktop.

There's no .license file but there is a license.key one. The current info for it is
Code: Select all
-rw-r--r--  1 kai  admin       77  7 Jun 10:12 .license_key


If the problem occurs again I'll revisit that.
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

Go ahead and keep it where you prefer..

Postby jeff » Wed Jun 08, 2005 9:01 am

Sorry, I forgot the name of the file :oops:

I want you to be able to keep the application wherever you want. I wasn't sure if the permissions prevented the file from being read while in the root level apps folder, although that should not be a problem.

The plan is to store the license in the preferences folder instead of the BeerBot folder in future revisions. If you discover anything that you think may be a clue, please let me know. We are determined to get it fixed, thanks again!
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1401
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

it happened again

Postby goodbyesoberday » Mon Jun 20, 2005 8:03 am

After a good run, BeerBot has forgotten its rego information again and my license key has now expired.

A quick peek in the folder, the license.key file is still there, it appears to still contain the same information (though hard to tell asusming it's encrypted) and the info for the file is still thusly:
Code: Select all
-rw-r--r--  1 kai  admin       77  7 Jun 10:12 .license_key


For the duration, is it possible for you email me an updated license code?
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

Have you changed anything?

Postby jeff » Mon Jun 20, 2005 10:30 am

Can you recall any changes that you have made with your computer recently? New peripherals, network configuration, memory? It may seem completely unrelated, but post it anyway because there may be a link and may provide the answer to the problem. Thanks for your help!
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1401
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

nope, nothing

Postby goodbyesoberday » Wed Jun 22, 2005 12:45 am

No new hardware or changes in network configs. I even tried plugging and unplugging my bluetooth dongle which I use occasionally but couldn't reproduce the problem.

I'll keep beerbot open so I can see as soon as possible if it loses it's rego information again, so I can think of what I was doing immediately prior.
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

and again

Postby goodbyesoberday » Wed Jul 20, 2005 3:28 am

This time, though I can say I am medium-certain as to what caused it. I installed the Airport update through SW update, restarted, and it's again unlicensed. Prior to that it had been fine.
goodbyesoberday
Light Lager
Light Lager
 
Posts: 16
Joined: Thu May 26, 2005 1:48 am

Thanks for the details..

Postby jeff » Fri Jul 22, 2005 8:45 am

Hopefully, it wasn't just a coincidence, and Software Update has something to do with it. That would provide some leads on what to check for. Perhaps you can post some information about your system layout; OS, RAM, HD, peripherals, etc. Man, feels like I'm investigating a crime! Thanks for the patience, and the help!
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1401
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

Next

Return to BeerBot

Who is online

Users browsing this forum: No registered users and 0 guests