Interesting search behavior

Found a problem? Post details on BeerTools Pro errors and how they are caused.

Interesting search behavior

Postby bpylant » Sun May 24, 2015 11:54 am

Not sure if this an actual bug, but it is a bit odd:

If I type '565' in the search field BTP does not find White Labs WLP565 (I assume because it is looking for the entire string and I didn't include 'WLP').

However, if I type 'WLP565' it finds both 565 and 566, which implies that it is searching for partial matches as well as complete.

Weird, eh?
BTP 2.0.12 / Database 8.0

Computer Info:
Mac OS X 10.9.5
2.53 GHz Intel Core i7
8 GB RAM
User avatar
bpylant
Pale Ale
Pale Ale
 
Posts: 79
Joined: Tue Oct 31, 2006 11:31 pm
Location: Merchantville NJ

Re: Interesting search behavior

Postby jeff » Mon May 25, 2015 5:07 pm

WLP565 is found in the description of WLP566 which is why it comes up in the search, too.
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1482
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC

Re: Interesting search behavior

Postby bpylant » Mon May 25, 2015 9:35 pm

Ahhh, makes sense! :)
BTP 2.0.12 / Database 8.0

Computer Info:
Mac OS X 10.9.5
2.53 GHz Intel Core i7
8 GB RAM
User avatar
bpylant
Pale Ale
Pale Ale
 
Posts: 79
Joined: Tue Oct 31, 2006 11:31 pm
Location: Merchantville NJ

Re: Interesting search behavior

Postby jeff » Tue May 26, 2015 3:59 pm

If I’m not mistaken, the search will return a result when the search phrase is found at the start of a word rather than in the middle of one. That’s why “565” doesn’t return a result while “WLP565” does.
Jeff
BeerTools.com Staff
User avatar
jeff
Imperial Stout
Imperial Stout
 
Posts: 1482
Joined: Sun Jan 09, 2000 9:16 pm
Location: Hollywood, SC


Return to BeerTools Pro Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron